[Flac-dev] anyone run FLAC on FreeBSD 4.8?

Derek at CD Baby dereklist at cdbaby.com
Thu Jun 5 22:26:04 PDT 2003

> I don't know if it's any help or not, but I'm using the NetBSD package and
> it works ok. So you might look at the makefile and patches for that to see
> if it does anything different.
> > On a virgin FreeBSD 4.8 system, I've tried to use the FLAC audio compression port:
> > /usr/ports/audio/flac
> > Using no special options on a .wav file:
> > flac mysong.wav
> > I get "Illegal instruction (core dumped)".
> > I've tried it on 3 different FreeBSD 4.8 boxes, and many different .wav files.
> > Has anyone gotten it to work?
> > Is it just a problem with the FreeBSD makefile?

Ah!  I just uninstalled the FreeBSD port, and just installed the raw tarball
using ./configure ; gmake ; gmake install - and it works great!

So - I guess the FreeBSD port is broken.  It says last updated 2001, though it's
using the newest version of FLAC.  Strange.  Wish I knew how to fix ports.

More information about the Flac-dev mailing list